gmp: upgrade to 4.3.1 and fix compile on 64-bit mac os x
[openwrt/svn-archive/archive.git] / tools / gmp / Makefile
index 4c6fac425f93eddf7e3c338cca6a892974036772..3f6e7923989321fc4b5992fbdb8eabaa777238ca 100644 (file)
@@ -7,36 +7,34 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=4.2.4
+PKG_VERSION:=4.3.1
 
 PKG_SOURCE_URL:=@GNU/gmp/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=
+PKG_MD5SUM:=26cec15a90885042dd4a15c4003b08ae
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --enable-cxx \
-         --enable-mpbsd \
-       );
-endef
+unexport CFLAGS
 
-define Host/Compile
-       make -C $(HOST_BUILD_DIR) all
-endef
+ifeq ($(HOST_OS),Darwin)
+  GNU_HOST_NAME:=
+  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
+endif
 
-define Host/Install
-       make -C $(HOST_BUILD_DIR) install
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --enable-cxx \
+       --enable-mpbsd
 
-define Host/Clean
-       rm -rf $(HOST_BUILD_DIR)
+define Host/Configure
+       (cd $(HOST_BUILD_DIR)/$(3); \
+               $(HOST_CONFIGURE_CMD) \
+               $(HOST_CONFIGURE_VARS) \
+               $(HOST_CONFIGURE_ARGS); \
+       )
 endef
 
+
 $(eval $(call HostBuild))