mediatek: bump to v4.4
[openwrt/svn-archive/archive.git] / tools / mpc / Makefile
index ab799b269e52750cc2231501c3791013e6801c4b..f0bf8f4589ee081bd415446936cc0a0f0bc2ebee 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpc
-PKG_VERSION:=0.8.2
+PKG_VERSION:=1.0.3
 
-PKG_SOURCE_URL:=http://www.multiprecision.org/mpc/download/
+PKG_SOURCE_URL:=@GNU/mpc/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=e98267ebd5648a39f881d66797122fb6
+PKG_MD5SUM:=d6a1d5f8ddea3abd2cc3e98f58352d26
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -23,13 +25,4 @@ HOST_CONFIGURE_ARGS += \
        --with-mpfr=$(TOPDIR)/staging_dir/host \
        --with-gmp=$(TOPDIR)/staging_dir/host
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR)/$(3); \
-               $(HOST_CONFIGURE_CMD) \
-               $(HOST_CONFIGURE_VARS) \
-               $(HOST_CONFIGURE_ARGS); \
-       )
-endef
-
-
 $(eval $(call HostBuild))