clean up gmp and mpfr
[openwrt/svn-archive/archive.git] / tools / mpfr / Makefile
index 84dc9ec29fe56d8d809e3bb892e353638edec959..17734a246a0e3944b2f336392eee72980f187ba5 100644 (file)
@@ -9,33 +9,15 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=mpfr
 PKG_VERSION:=2.3.2
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-current/
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-2.3.2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --with-gmp=$(STAGING_DIR_HOST) \
-       );
-endef
-
-define Build/Compile
-       make -C $(PKG_BUILD_DIR) all
-endef
-
-define Build/Install
-       make -C $(PKG_BUILD_DIR) install
-endef
-
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-gmp=$(STAGING_DIR_HOST)
 
 $(eval $(call HostBuild))