tools/mpfr enable parallel builds
[openwrt/svn-archive/archive.git] / tools / mpfr / Makefile
index 84dc9ec29fe56d8d809e3bb892e353638edec959..55c329ff8c33b6a0abda1b7318a1fb858171c373 100644 (file)
@@ -7,35 +7,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=2.3.2
+PKG_VERSION:=3.0.0
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-current/
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
+PKG_MD5SUM:=f45bac3584922c8004a10060ab1a8f9f
 
-include $(INCLUDE_DIR)/host-build.mk
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --with-gmp=$(STAGING_DIR_HOST) \
-       );
-endef
+HOST_BUILD_PARALLEL:=1
+HOST_FIXUP:=autoreconf
 
-define Build/Compile
-       make -C $(PKG_BUILD_DIR) all
-endef
-
-define Build/Install
-       make -C $(PKG_BUILD_DIR) install
-endef
+include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-gmp=$(STAGING_DIR_HOST)
 
 $(eval $(call HostBuild))