[tools] mpfr: reenable HOST_FIXUP, it *should* work okay now after r24570
[openwrt/svn-archive/archive.git] / tools / mpfr / Makefile
index 84dc9ec29fe56d8d809e3bb892e353638edec959..72712f219dc2c7426e8b7aeaeee8395bf13ce4c6 100644 (file)
@@ -7,35 +7,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=2.3.2
+PKG_VERSION:=3.0.0
 
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-current/
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
+PKG_MD5SUM:=f45bac3584922c8004a10060ab1a8f9f
 
 
-include $(INCLUDE_DIR)/host-build.mk
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --with-gmp=$(STAGING_DIR_HOST) \
-       );
-endef
+HOST_FIXUP:=autoreconf
 
 
-define Build/Compile
-       make -C $(PKG_BUILD_DIR) all
-endef
+include $(INCLUDE_DIR)/host-build.mk
 
 
-define Build/Install
-       make -C $(PKG_BUILD_DIR) install
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-gmp=$(STAGING_DIR_HOST)
 
 
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
+define Host/Configure
+       echo "PATH=$(shell echo $$PATH)"
+       $(call Host/Configure/Default)
 endef
 
 $(eval $(call HostBuild))
 endef
 
 $(eval $(call HostBuild))