[tools] convert remaining tools to $(HOST_STATIC_LINKING) (#12012)
[openwrt/svn-archive/archive.git] / tools / squashfs4 / Makefile
index ddbca1140345340cb4d2ddc5dd963567608ac73a..b838b46c55a10e2091d8fd54e6a77bf602a16ac1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squashfs4
-PKG_VERSION:=4.0
+PKG_VERSION:=4.2
 
 PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/squashfs
-PKG_MD5SUM:=a3c23391da4ebab0ac4a75021ddabf96
+PKG_MD5SUM:=1b7a781fb4cf8938842279bd3e8ee852
 PKG_CAT:=zcat
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/squashfs$(PKG_VERSION)
@@ -20,9 +20,13 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
-               USE_LZMA=1 \
-               LZMA_CFLAGS="-I$(STAGING_DIR_HOST)/include -DUSE_LZMA" \
+               CC="$(HOSTCC)" \
+               XZ_SUPPORT=1 \
+               LZMA_XZ_SUPPORT=1 \
+               XATTR_SUPPORT= \
                LZMA_LIB="$(STAGING_DIR_HOST)/lib/liblzma.a" \
+               EXTRA_CFLAGS="-I$(STAGING_DIR_HOST)/include" \
+               EXTRA_LDFLAGS="$(HOST_STATIC_LINKING)" \
                mksquashfs unsquashfs
 endef