[tools] sstrip: Correct include path to really get endian.h
[openwrt/svn-archive/archive.git] / tools / sstrip / Makefile
index f978eae2647f333f5df9d3e10fc27a30300d6eca..0d3576a53f5c743740b31356bee12286979b473e 100644 (file)
@@ -7,27 +7,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sstrip
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
 
 include $(INCLUDE_DIR)/host-build.mk
 
-OS:=$(shell uname)
-ifeq ($(HOST_OS),Darwin)
-  CFLAGS += -I./include
-endif
-CFLAGS += -I $(TOPDIR)/tools/include -include endian.h
-
-define Build/Compile
-       $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
+define Host/Compile
+       $(CC) $(HOST_CFLAGS) -I$(TOPDIR)/tools/include -include endian.h -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
 endef
 
-define Build/Install
-       mkdir -p $(STAGING_DIR)/bin
-       $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR)/bin/
+define Host/Install
+       $(CP) $(HOST_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
 endef
 
-define Build/Clean
-       rm -f $(STAGING_DIR)/bin/sstrip
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/sstrip
 endef
 
 $(eval $(call HostBuild))