[packages] Mass Fix for GCC 4.6
[openwrt/svn-archive/archive.git] / utils / avrusbboot / Makefile
index e8a21a3223ea5febb647c4288b48bcff27f18124..378b07655f86d8769dcf15d52d938b90158d936d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avrusbboot
 PKG_VERSION:=2006-06-25
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.fischl.de/avrusbboot/
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/avrusbboot
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libusb +uclibcxx +libgcc
+  DEPENDS:=+libusb +uclibcxx
   TITLE:=USB bootloader for Atmel AVR controllers
   URL:=http://www.fischl.de/avrusbboot/
 endef
@@ -41,7 +41,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/software \
                CXX="$(TARGET_CROSS)g++ $(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++ $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++" \
-               LFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ -lusb $(LIBGCC_S)" \
+               LFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -lc -luClibc++ -lc -lusb $(LIBGCC_S)" \
                all
 endef