Remove broken patch which was causing the path to be incremented as well as the file...
[openwrt/svn-archive/archive.git] / utils / bandwidthd / Makefile
index 4a9aac4481d293aaf0411a34672761ffcf5d3912..62c1963ec156fe5f9b51b7a9d3fec89724d39f71 100644 (file)
@@ -44,8 +44,12 @@ EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
 define Package/bandwidthd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/bandwidthd $(1)/usr/sbin/
 define Package/bandwidthd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/bandwidthd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/bandwidthd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/bandwidthd.config $(1)/etc/config/bandwidthd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/bandwidthd.init $(1)/etc/init.d/bandwidthd
+       $(INSTALL_DIR) $(1)/www
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/htdocs/legend.gif $(1)/www/
 endef
 
 $(eval $(call BuildPackage,bandwidthd))
 endef
 
 $(eval $(call BuildPackage,bandwidthd))