[batman-adv] batctl replaces battool for testing / debugging / configuration
[openwrt/svn-archive/archive.git] / utils / bash / Makefile
index 7588117eb4ddc08e658707c20a564eeec26d393d..e8075b7f95ae49407ce4ba078a82f3f80cec48b9 100644 (file)
@@ -1,30 +1,27 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bash
 PKG_VERSION:=3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/bash/
+PKG_SOURCE_URL:=@GNU/bash
 PKG_MD5SUM:=00bfa16d58e034e3c2aa27f390390d30
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bash
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=The GNU Bourne Again SHell
+  DEPENDS:=+libncurses
   URL:=http://www.gnu.org/software/bash/
 endef
 
@@ -35,13 +32,11 @@ define Package/bash/description
 endef
 
 
-define Build/Configure 
+define Build/Configure
        $(call Build/Configure/Default, \
                --disable-restricted \
                --without-bash-malloc \
-                --bindir=/bin, \
-               ac_cv_func_bcopy=yes \
-               ac_cv_func_bzero=yes \
+                --bindir=/bin \
        )
 endef
 
@@ -54,6 +49,12 @@ define Build/Compile
                all install
 endef
 
+define Package/bash/postinst
+#!/bin/sh
+grep bash $${IPKG_INSTROOT}/etc/shells || \
+       echo "/bin/bash" >> $${IPKG_INSTROOT}/etc/shells
+endef
+
 define Package/bash/install
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/bash $(1)/bin/