[packages] ipv6calc: update to v0.73.0 (#5912)
[openwrt/svn-archive/archive.git] / utils / bash / Makefile
index e8863fecc79e89fb50c6e6fd58da2ab12bf95bf0..e8075b7f95ae49407ce4ba078a82f3f80cec48b9 100644 (file)
@@ -1,24 +1,19 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bash
 PKG_VERSION:=3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/bash/
+PKG_SOURCE_URL:=@GNU/bash
 PKG_MD5SUM:=00bfa16d58e034e3c2aa27f390390d30
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,15 +21,18 @@ define Package/bash
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=The GNU Bourne Again SHell
-  DESCRIPTION:=\
-       Bash is an sh-compatible command language interpreter that executes \\\
-       commands read from the standard input or from a file.  Bash also \\\
-       incorporates useful features from the Korn and C shells (ksh and csh). 
+  DEPENDS:=+libncurses
   URL:=http://www.gnu.org/software/bash/
 endef
 
+define Package/bash/description
+       Bash is an sh-compatible command language interpreter that executes 
+       commands read from the standard input or from a file. Bash also 
+       incorporates useful features from the Korn and C shells (ksh and csh).
+endef
+
 
-define Build/Configure 
+define Build/Configure
        $(call Build/Configure/Default, \
                --disable-restricted \
                --without-bash-malloc \
@@ -51,9 +49,15 @@ define Build/Compile
                all install
 endef
 
+define Package/bash/postinst
+#!/bin/sh
+grep bash $${IPKG_INSTROOT}/etc/shells || \
+       echo "/bin/bash" >> $${IPKG_INSTROOT}/etc/shells
+endef
+
 define Package/bash/install
        $(INSTALL_DIR) $(1)/bin
-       $(CP) $(PKG_INSTALL_DIR)/bin/bash $(1)/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/bash $(1)/bin/
 endef
 
 $(eval $(call BuildPackage,bash))