packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / utils / bemused / Makefile
index 08588dd4b6027e0094d90081d925325a9f28878b..4cd0b13a3733fe76c6a7ba270318a9b4db3a17ba 100644 (file)
@@ -1,50 +1,52 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bemused-mpd
-PKG_VERSION:=r047
-PKG_RELEASE:=1
+PKG_VERSION:=r062
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/382
-PKG_MD5SUM:=f40715812d59d2ab1bd93f96c5e8818b
+PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/526
+PKG_MD5SUM:=aed8b41aed530e9177e43d9bebad10b7
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/bemusedlinuxserver
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+bluez-libs +glib1 +mpd +libstdcpp
+  DEPENDS:=+bluez-libs +glib1 +mpd +libstdcpp $(ICONV_DEPENDS)
   TITLE:=Bemused linux server
   URL:=http://bemused-lnx-mpdhack.origo.ethz.ch/
 endef
 
 define Package/bemusedlinuxserver/description
-    Bemused is a system which allows you to control your music collection 
+    Bemused is a system which allows you to control your music collection
     from your phone, using Bluetooth.
     This is the MPD hack version.
     Check http://jamse.sourceforge.net/ for a mobile phone client.
 endef
 
+EXTRA_CPPFLAGS:= \
+       -I$(STAGING_DIR)/usr/include/glib-1.2 \
+       -I$(STAGING_DIR)/usr/lib/glib/include
+
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-       $(TARGET_CONFIGURE_OPTS) \
-       CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
-       LDFLAGS="$(TARGET_LDFLAGS) " \
-       CPPFLAGS="$(TARGET_CPPFLAGS)" \
-       INCL="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include" \
-       MYLIBS="-lbluetooth -lglib"
-       $(STRIP) $(PKG_BUILD_DIR)/bemusedlinuxserver
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+               CXXFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
+               LDLIBS="-lbluetooth -lglib -liconv"
 endef
 
 define Package/bemusedlinuxserver/install
@@ -57,4 +59,9 @@ define Package/bemusedlinuxserver/install
        $(INSTALL_BIN) ./files/bemused.init $(1)/etc/init.d/bemused
 endef
 
+define Package/bemusedlinuxserver/conffiles
+/etc/bemused.conf
+/etc/bemused-bookmarks
+endef
+
 $(eval $(call BuildPackage,bemusedlinuxserver))