Fix libtiff install.
[openwrt/svn-archive/archive.git] / utils / bemused / Makefile
index 08588dd4b6027e0094d90081d925325a9f28878b..b58dfcb0f6fe65c2c12ef6b6aebb7fd9e37f682c 100644 (file)
@@ -9,28 +9,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bemused-mpd
-PKG_VERSION:=r047
+PKG_VERSION:=r062
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/382
-PKG_MD5SUM:=f40715812d59d2ab1bd93f96c5e8818b
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/526
+PKG_MD5SUM:=aed8b41aed530e9177e43d9bebad10b7
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bemusedlinuxserver
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+bluez-libs +glib1 +mpd +libstdcpp
+  DEPENDS:=+bluez-libs +glib1 +mpd +libstdcpp +libiconv
   TITLE:=Bemused linux server
   URL:=http://bemused-lnx-mpdhack.origo.ethz.ch/
 endef
 
 define Package/bemusedlinuxserver/description
-    Bemused is a system which allows you to control your music collection 
+    Bemused is a system which allows you to control your music collection
     from your phone, using Bluetooth.
     This is the MPD hack version.
     Check http://jamse.sourceforge.net/ for a mobile phone client.
@@ -42,8 +39,8 @@ define Build/Compile
        CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS) " \
        CPPFLAGS="$(TARGET_CPPFLAGS)" \
-       INCL="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include" \
-       MYLIBS="-lbluetooth -lglib"
+       INCL="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include -I$(STAGING_DIR)/usr/lib/libiconv/include" \
+       MYLIBS="-lbluetooth -lglib -L$(STAGING_DIR)/usr/lib/libiconv/lib -liconv"
        $(STRIP) $(PKG_BUILD_DIR)/bemusedlinuxserver
 endef