bluez-utils: sdpd is no longer a separate daemon.
[openwrt/svn-archive/archive.git] / utils / bluez-utils / Makefile
index 95b25a97035f3cbbda24f679c821be49335df810..3c002dcb901dc772755e47d59dd2916ff2ea0662 100644 (file)
@@ -9,22 +9,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
-PKG_VERSION:=3.24
-PKG_RELEASE:=1
+PKG_VERSION:=3.36
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
-PKG_MD5SUM:=cc3582da827bc4c468147af1afaa5aff
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=4fc292b635ba7b442c7aaf5680199012
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bluez-utils
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+bluez-libs +libpthread +dbus
+  DEPENDS:=+bluez-libs +libpthread +dbus +libintl +libiconv
   TITLE:=Bluetooth utilities
   URL:=http://www.bluez.org/
 endef
@@ -35,21 +32,24 @@ define Package/bluez-utils/conffiles
 /etc/config/bluetooth
 endef
 
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-debug \
-               --enable-usb \
-               --enable-input \
-               --enable-serial \
-               --enable-network \
-               --with-bluez="$(STAGING_DIR)/usr/include" \
-               --with-usb=yes \
-       )
-endef
+CONFIGURE_ARGS += \
+       --disable-glib \
+       --enable-pand \
+       --enable-rfcomm \
+       --enable-dund \
+       --enable-serial \
+       --enable-network \
+       --enable-usb \
+       --enable-input \
+       --disable-audio \
+       --with-bluez="$(STAGING_DIR)/usr/include" \
+       --with-usb=yes \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib \
+                       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+                       -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
@@ -61,14 +61,13 @@ define Package/bluez-utils/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/../daemon/passkey-agent $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/bluetooth
        $(CP) $(PKG_INSTALL_DIR)/../hcid/hcid.conf $(1)/etc/bluetooth/
        $(CP) $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf $(1)/etc/bluetooth/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/bluetooth.conf $(1)/etc/config/bluetooth
        $(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/../daemon/bluetooth.conf $(1)/etc/dbus-1/system.d/
+       $(INSTALL_DATA) ./files/bluetooth.dbus $(1)/etc/dbus-1/system.d/bluetooth.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/bluez-utils.init $(1)/etc/init.d/bluez-utils
 endef