bluez-utils: sdpd is no longer a separate daemon.
[openwrt/svn-archive/archive.git] / utils / bluez-utils / Makefile
index ec4f49e849d3a4a602c2a65996a7d69ea8839896..3c002dcb901dc772755e47d59dd2916ff2ea0662 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
 PKG_VERSION:=3.36
-PKG_RELEASE:=1
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
@@ -33,6 +33,7 @@ define Package/bluez-utils/conffiles
 endef
 
 CONFIGURE_ARGS += \
+       --disable-glib \
        --enable-pand \
        --enable-rfcomm \
        --enable-dund \
@@ -66,6 +67,7 @@ define Package/bluez-utils/install
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/bluetooth.conf $(1)/etc/config/bluetooth
        $(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
+       $(INSTALL_DATA) ./files/bluetooth.dbus $(1)/etc/dbus-1/system.d/bluetooth.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/bluez-utils.init $(1)/etc/init.d/bluez-utils
 endef