[packages] lftp: update to 4.1.3
[openwrt/svn-archive/archive.git] / utils / bluez-utils / Makefile
index ec4f49e849d3a4a602c2a65996a7d69ea8839896..876d7808d3183b95ed387601b8bc44db7bcba453 100644 (file)
@@ -1,27 +1,29 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
 PKG_VERSION:=3.36
-PKG_RELEASE:=1
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
 PKG_MD5SUM:=4fc292b635ba7b442c7aaf5680199012
 
+PKG_FIXUP:=libtool
+
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/bluez-utils
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+bluez-libs +libpthread +dbus +libintl +libiconv
+  DEPENDS:=+bluez-libs +libpthread +dbus $(INTL_DEPENDS) $(ICONV_DEPENDS)
   TITLE:=Bluetooth utilities
   URL:=http://www.bluez.org/
 endef
@@ -33,6 +35,7 @@ define Package/bluez-utils/conffiles
 endef
 
 CONFIGURE_ARGS += \
+       --disable-glib \
        --enable-pand \
        --enable-rfcomm \
        --enable-dund \
@@ -46,9 +49,9 @@ CONFIGURE_ARGS += \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib \
-                       -L$(STAGING_DIR)/usr/lib/libintl/lib \
-                       -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
+               LDFLAGS="$(TARGET_LDFLAGS) \
+                       -L$(ICONV_PREFIX)/lib \
+                       -L$(INTL_PREFIX)/lib" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
@@ -66,6 +69,7 @@ define Package/bluez-utils/install
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/bluetooth.conf $(1)/etc/config/bluetooth
        $(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
+       $(INSTALL_DATA) ./files/bluetooth.dbus $(1)/etc/dbus-1/system.d/bluetooth.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/bluez-utils.init $(1)/etc/init.d/bluez-utils
 endef