Update bluez-utils to 3.36 (#3765)
[openwrt/svn-archive/archive.git] / utils / bluez-utils / Makefile
index 0d3c2980b987c21a93e56b3665f4ba2a7bf6bd4a..ec4f49e849d3a4a602c2a65996a7d69ea8839896 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,71 +9,63 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
-PKG_VERSION:=2.24
-PKG_RELEASE:=3
+PKG_VERSION:=3.36
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
-PKG_MD5SUM:=5f5488ff3d31bdb9cd36b7991fe68408
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=4fc292b635ba7b442c7aaf5680199012
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bluez-utils
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+bluez-libs +libpthread
+  DEPENDS:=+bluez-libs +libpthread +dbus +libintl +libiconv
   TITLE:=Bluetooth utilities
   URL:=http://www.bluez.org/
 endef
 
 define Package/bluez-utils/conffiles
-/etc/bluetooth/givepin
 /etc/bluetooth/hcid.conf
 /etc/bluetooth/rfcomm.conf
 /etc/config/bluetooth
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-dbus \
-               --disable-fuse \
-               --disable-obex \
-               --disable-alsa \
-               --disable-cups \
-               --disable-pcmcia \
-               --disable-initscripts \
-               --disable-bccmd \
-               --disable-avctrl \
-               --disable-hid2hci \
-               --disable-dfutool \
-               --disable-bcm203x \
-               --disable-bluepin \
-               --with-bluez="$(STAGING_DIR)/usr/include" \
-               --with-usb=no \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-pand \
+       --enable-rfcomm \
+       --enable-dund \
+       --enable-serial \
+       --enable-network \
+       --enable-usb \
+       --enable-input \
+       --disable-audio \
+       --with-bluez="$(STAGING_DIR)/usr/include" \
+       --with-usb=yes \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib \
+                       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+                       -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
+#copy bluetooth.conf nach /etc/dbus-1/system.d/
+
 define Package/bluez-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/bluetooth
        $(CP) $(PKG_INSTALL_DIR)/../hcid/hcid.conf $(1)/etc/bluetooth/
        $(CP) $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf $(1)/etc/bluetooth/
-       install -m0700 ./files/givepin $(1)/etc/bluetooth/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/bluetooth.conf $(1)/etc/config/bluetooth
+       $(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/bluez-utils.init $(1)/etc/init.d/bluez-utils
 endef