Added dependency libraries to ensure configure can find and use librrd.so
[openwrt/svn-archive/archive.git] / utils / cifsmount / Makefile
index 147e09b500675e0065ef5e658b5e7df91b3c99b0..d2f79a41551d5a92920aeb6ca0df590da2215803 100644 (file)
@@ -20,24 +20,21 @@ define Package/cifsmount
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=CIFS mounting helper utility
-  DESCRIPTION:=Helper utility for mounting remote CIFS shares.\\\
-    An user space helper for mounting remote CIFS shares
+  DESCRIPTION:=\
+       An user space helper utility for mounting remote CIFS shares.
 endef
 
 define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
 endef
 
-define Build/Configure
-endef
-
 define Build/Compile
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mount.cifs mount.cifs.c
 endef
 
 define Package/cifsmount/install
-       install -d -m0755 $(1)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/mount.cifs $(1)/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount.cifs $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,cifsmount))