Add a default configuration file (#1404)
[openwrt/svn-archive/archive.git] / utils / cifsmount / Makefile
index 9cc4c3a95e508883696b7806d5de32b06c6fbfd6..d2f79a41551d5a92920aeb6ca0df590da2215803 100644 (file)
@@ -20,8 +20,8 @@ define Package/cifsmount
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=CIFS mounting helper utility
-  DESCRIPTION:=Helper utility for mounting remote CIFS shares.\\\
-    An user space helper for mounting remote CIFS shares
+  DESCRIPTION:=\
+       An user space helper utility for mounting remote CIFS shares.
 endef
 
 define Build/Prepare
@@ -33,8 +33,8 @@ define Build/Compile
 endef
 
 define Package/cifsmount/install
-       install -d -m0755 $(1)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/mount.cifs $(1)/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount.cifs $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,cifsmount))