[package] fix zlib dependency typo in collectd Makefile (#5457)
[openwrt/svn-archive/archive.git] / utils / collectd / Makefile
index 8ae8d1d7b893c2bc883770a247b8f90b9eebb613..14599a8eaeeedb0971ae78ef8fd76785b42815e3 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -17,7 +16,6 @@ PKG_SOURCE_URL:=http://collectd.org/files/
 PKG_MD5SUM:=9e0e89150b1ff28fc0fdd8a198c9ac5e
 
 PKG_FIXUP=libtool
-PKG_BUILD_DEPENDS:=+libxml2 +libnetsnmp +libcurl +librrd1
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -36,7 +34,7 @@ endef
 
 define Package/collectd
         $(call Package/collectd/common_info)
-        DEPENDS:=+libgcc +libpthread
+        DEPENDS:=+libgcc +libpthread +zlib
         MENU:=1
 endef
 
@@ -281,7 +279,7 @@ PKG_CONFIGURE_OPTS:= \
        --with-fp-layout=nothing
 
 CONFIGURE_VARS+= \
-       CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS" \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS $(FPIC)" \
        KERNEL_DIR="$(LINUX_DIR)"
 
 # list of permanently disabled plugins
@@ -316,7 +314,7 @@ endif
 # exception: mod-rrdtool(1) needs rrdtool
 ifneq ($(CONFIG_PACKAGE_collectd-mod-rrdtool1),)
        PKG_CONFIGURE_OPTS += --with-rrdtool=$(wildcard $(BUILD_DIR)/rrdtool-1.0.*)
-       TARGET_LDFLAGS := -L$(wildcard $(BUILD_DIR)/rrdtool-1.0.*)/src/.libs -lz $(TARGET_LDFLAGS)
+       TARGET_LDFLAGS := -L$(wildcard $(BUILD_DIR)/rrdtool-1.0.*)/src/.libs -lz -lm $(TARGET_LDFLAGS)
 endif