[Packages] devio:
[openwrt/svn-archive/archive.git] / utils / devio / Makefile
index 3684b501b0182b5736ab02353a0894b61c8aa2cc..198276c2728e888d8becb277081e8d82fe87372c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -16,14 +16,13 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/devio
 PKG_MD5SUM:=5d332c2bffc0791367bcf3368ba1a0d1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/devio
+  SUBMENU:=disc
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=Correctly write to and read from mtd character (and other block) devices
+  TITLE:=correctly read (or write) a region of a block device
   URL:=http://sourceforge.net/projects/devio/
 endef
 
@@ -32,19 +31,6 @@ define Package/devio/description
        Primary use is for extracting formatted data from MTD partitions.
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR) ; \
-               ./configure \
-       );
-endef
-
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(EXTRA_CFLAGS)" \
-               LDFLAGS="$(EXTRA_LDFLAGS)" \
-       )
-endef
-
 define Package/devio/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/devio $(1)/usr/sbin