Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / utils / dosfstools / Makefile
index 0f2adaf50b32997dd44c378b20ca609568ba7183..98cfebea1af2ec36f7ca8f6ce8c54075988e45b9 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,15 +10,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dosfstools
 PKG_VERSION:=2.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/
 PKG_MD5SUM:=407d405ade410f7597d364ab5dc8c9f6
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,9 +22,12 @@ define Package/dosfstools
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=MS-DOS FAT filesystems utilities
-  DESCRIPTION:=\
-       Utilities to create and check MS-DOS FAT filesystems.
   URL:=ftp://ftp.uni-erlangen.de:/pub/Linux/LOCAL/dosfstools/
+  SUBMENU:=filesystem
+endef
+
+define Package/dosfstools/description
+       Utilities to create and check MS-DOS FAT filesystems.
 endef
 
 define Build/Configure
@@ -50,11 +49,11 @@ define Build/Compile
 endef
 
 define Package/dosfstools/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dosfsck $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/fsck.{msdos,vfat} $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mkdosfs $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mkfs.{msdos,vfat} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dosfsck $(1)/usr/sbin/
+       (cd $(1)/usr/sbin; ln -s dosfsck fsck.msdos; ln -s dosfsck fsck.vfat)
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mkdosfs $(1)/usr/sbin/
+       (cd $(1)/usr/sbin; ln -s mkdofs mkfs.msdos; ln -s mkdofs mkfs.vfat)
 endef
 
 $(eval $(call BuildPackage,dosfstools))