Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / utils / dosfstools / Makefile
index 97d25d96418f8736d7a3a1441f345fb2a016ddb4..98cfebea1af2ec36f7ca8f6ce8c54075988e45b9 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,15 +10,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dosfstools
 PKG_VERSION:=2.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/
 PKG_MD5SUM:=407d405ade410f7597d364ab5dc8c9f6
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dosfstools
@@ -26,6 +23,7 @@ define Package/dosfstools
   CATEGORY:=Utilities
   TITLE:=MS-DOS FAT filesystems utilities
   URL:=ftp://ftp.uni-erlangen.de:/pub/Linux/LOCAL/dosfstools/
+  SUBMENU:=filesystem
 endef
 
 define Package/dosfstools/description
@@ -52,10 +50,10 @@ endef
 
 define Package/dosfstools/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dosfsck $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/fsck.{msdos,vfat} $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mkdosfs $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mkfs.{msdos,vfat} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dosfsck $(1)/usr/sbin/
+       (cd $(1)/usr/sbin; ln -s dosfsck fsck.msdos; ln -s dosfsck fsck.vfat)
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mkdosfs $(1)/usr/sbin/
+       (cd $(1)/usr/sbin; ln -s mkdofs mkfs.msdos; ln -s mkdofs mkfs.vfat)
 endef
 
 $(eval $(call BuildPackage,dosfstools))