Add a default configuration file (#1404)
[openwrt/svn-archive/archive.git] / utils / dosfstools / Makefile
index 46dd99067a93bacc06c61b476d5c01b8ae2c2256..ff62f026a86873a27c6462ce5433bee31c37fe1b 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=dosfstools
 PKG_VERSION:=2.11
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_MD5SUM:=407d405ade410f7597d364ab5dc8c9f6
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/
+PKG_MD5SUM:=407d405ade410f7597d364ab5dc8c9f6
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -26,8 +26,8 @@ define Package/dosfstools
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=MS-DOS FAT filesystems utilities
-  DESCRIPTION:=MS-DOS FAT filesystems utilities.\\\
-    Utilities to create and check MS-DOS FAT filesystems.
+  DESCRIPTION:=\
+       Utilities to create and check MS-DOS FAT filesystems.
   URL:=ftp://ftp.uni-erlangen.de:/pub/Linux/LOCAL/dosfstools/
 endef
 
@@ -35,21 +35,26 @@ define Build/Configure
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                OPTFLAGS="$(TARGET_CFLAGS) -D_FILE_OFFSET_BITS=64" \
-               PREFIX="$(PKG_INSTALL_DIR)" \
-               all install
+               PREFIX="/usr" \
+               SBINDIR="/usr/sbin" \
+               all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               OPTFLAGS="$(TARGET_CFLAGS) -D_FILE_OFFSET_BITS=64" \
+               PREFIX="$(PKG_INSTALL_DIR)/usr" \
+               SBINDIR="$(PKG_INSTALL_DIR)/usr/sbin" \
+               install
 endef
 
 define Package/dosfstools/install
-       install -d -m0755 $(1)/sbin
-       $(CP) $(PKG_INSTALL_DIR)/sbin/dosfsck $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/fsck.{msdos,vfat} $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/mkdosfs $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/mkfs.{msdos,vfat} $(1)/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dosfsck $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/fsck.{msdos,vfat} $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mkdosfs $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mkfs.{msdos,vfat} $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,dosfstools))