add wxBase framework library
[openwrt/svn-archive/archive.git] / utils / fetchmail / Makefile
index 048fc3e5c376739f0fe32d5837080ab1093c4965..01b1cfaaabf1fe3354516a250f0a07ab9f183450 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=fetchmail
 PKG_VERSION:=6.2.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
 
-PKG_SOURCE_URL:=http://www.catb.org/~esr/fetchmail/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.catb.org/~esr/fetchmail/
+PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -26,7 +26,8 @@ define Package/fetchmail
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Remote mail retriever
-  DESCRIPTION:=Retrieves remote mail via POP/IMAP\\\
+  DESCRIPTION:=\
+       Retrieves remote mail via POP/IMAP.\\\
        Very useful in conjunction with mutt.
   URL:=http://www.catb.org/~esr/fetchmail/
 endef
@@ -34,22 +35,21 @@ endef
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-fallback=procmail \
-               --without-hesiod, \
+               --without-hesiod \
+               , \
                ac_cv_path_procmail=/usr/sbin/procmail \
        )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/fetchmail/install
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/fetchmail $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fetchmail))