Firmwarehotplug actually requires a sdcc that supports some targets, Debian lenny...
[openwrt/svn-archive/archive.git] / utils / firmwarehotplug / Makefile
index 372839206d8ae38935cfd6a1a2e717a82a6dbb41..16e5c977439dc373526e28bea8e58d1315148511 100644 (file)
@@ -15,9 +15,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linux-hotplug
 PKG_MD5SUM:=e5cf352b172f498e27b160167b981f24
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 # workaround for fedora sdcc naming changes
@@ -53,6 +50,16 @@ endef
 
 $(eval $(call BuildPackage,firmwarehotplug))
 
+define Require/working-sdcc
+       sdcc -v | awk '($$$$1 == "SDCC") && ($$$$3 == "mcs51/gbz80/z80/avr/ds390/pic16/pic14/TININative/xa51/ds400/hc08") { print "ok" }' | grep ok > /dev/null
+endef
+
 $(eval $(call RequireCommand,sdcc, \
         $(PKG_NAME) requires the SDCC Cross Compiler (sdcc). \
 ))
+
+$(eval $(call Require,working-sdcc, \
+        $(PKG_NAME) requires a SDCC Cross Compiler (sdcc) that supports the following targets : \
+       mcs51/gbz80/z80/avr/ds390/pic16/pic14/TININative/xa51/ds400/hc08. You might consider \
+       installing the non-free version. \
+))