[packages_10.03.1] collectd: backport r29404
[openwrt/svn-archive/archive.git] / utils / flashrom / Makefile
index 698dc430740fca10edeb6a3dd18ff7789a806388..b1e755595ecaece35b3fde9519a96458fea3a565 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2010 OpenWrt.org
+#
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,34 +8,38 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flashrom
-PKG_VERSION:=0.9.1
-PKG_RELEASE:=1
+PKG_VERSION:=0.9.3
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://qa.coreboot.org/releases/
-PKG_MD5SUM:=2b7cc0e45a0ac4c6d43c0f7cd05b041a
+PKG_SOURCE_URL:=http://download.flashrom.org/releases
+PKG_MD5SUM:=eccdec2764223f5d2839bf577380eaa9
 
-include $(INCLUDE_DIR)/package.mk
+PKG_INSTALL:=1
 
+include $(INCLUDE_DIR)/package.mk
 
 define Package/flashrom
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=FlashROM Utility
   URL:=http://www.flashrom.org/
-# XXX: needs <sys/io.h>, only available on theese arch right now
-  DEPENDS:=+zlib +pciutils @(arm||armeb||i386||i686||x86_64)
+# XXX: needs <sys/io.h>, only available on these arch right now
+  DEPENDS:=+zlib +pciutils +dmidecode @(arm||armeb||i386||i686||x86_64)
 endef
 
 define Package/flashrom/description
  flashrom is a utility for identifying, reading, writing, verifying
  and erasing flash chips. It's often used to flash BIOS/EFI/coreboot
- /firmware images. 
+ /firmware images.
 endef
 
+MAKE_FLAGS += \
+       PREFIX="/usr"
+
 define Package/flashrom/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/flashrom $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/flashrom $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,flashrom))