Ensure the host binary will be compile in 32bits mode
[openwrt/svn-archive/archive.git] / utils / fortune-mod / Makefile
index d48f4d783c643379a9075394a144a5796dc42937..25084e4533a38e72cd198d9bf660b66537478a28 100644 (file)
@@ -30,7 +30,7 @@ define Package/fortune-mod
 endef
 
 define Build/Compile
-       $(HOSTCC) -Wall -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
+       $(HOSTCC) -Wall -m32 -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
        $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/datfiles/fortunes $(PKG_BUILD_DIR)/datfiles/fortunes.dat
        $(MAKE) -C $(PKG_BUILD_DIR)/fortune
 endef