remove PKG_CAT from packages
[openwrt/svn-archive/archive.git] / utils / fortune-mod / Makefile
index d48f4d783c643379a9075394a144a5796dc42937..3af495417fa81d32cdae78d902af924b9af91366 100644 (file)
@@ -4,18 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fortune-mod
 PKG_VERSION:=1.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://freeware.sgi.com/source/fortune-mod
 PKG_MD5SUM:=383b1de06b35450235732c7ae7b5f0e3
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -25,10 +24,13 @@ define Package/fortune-mod
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=display fortune cookies on demand.
-  DESCRIPTION:=Fortune mod displays fortune cookies on demand
   URL:=http://freeware.sgi.com/source/fortune-mod
 endef
 
+define Package/fortune-mod/description
+Fortune mod displays fortune cookies on demand
+endef
+
 define Build/Compile
        $(HOSTCC) -Wall -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
        $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/datfiles/fortunes $(PKG_BUILD_DIR)/datfiles/fortunes.dat