[packages] collectd: remove redundant build dependencies
[openwrt/svn-archive/archive.git] / utils / fortune-mod / Makefile
index 25084e4533a38e72cd198d9bf660b66537478a28..d5e3dd8d35d31119b3c309f7fe727078e4d16d02 100644 (file)
@@ -4,18 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fortune-mod
 PKG_VERSION:=1.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://freeware.sgi.com/source/fortune-mod
 PKG_MD5SUM:=383b1de06b35450235732c7ae7b5f0e3
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -25,12 +23,15 @@ define Package/fortune-mod
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=display fortune cookies on demand.
-  DESCRIPTION:=Fortune mod displays fortune cookies on demand
   URL:=http://freeware.sgi.com/source/fortune-mod
 endef
 
+define Package/fortune-mod/description
+Fortune mod displays fortune cookies on demand
+endef
+
 define Build/Compile
-       $(HOSTCC) -Wall -m32 -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
+       $(HOSTCC) -Wall -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
        $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/datfiles/fortunes $(PKG_BUILD_DIR)/datfiles/fortunes.dat
        $(MAKE) -C $(PKG_BUILD_DIR)/fortune
 endef