DESCRIPTION:= is obselete
[openwrt/svn-archive/archive.git] / utils / fortune-mod / Makefile
index aaee901d76de17e14e1208945ade5cd91a859c31..dae5c45522f13b691515d5e79f277dd98cb971f8 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fortune-mod
 PKG_VERSION:=1.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://freeware.sgi.com/source/fortune-mod
@@ -25,12 +25,15 @@ define Package/fortune-mod
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=display fortune cookies on demand.
-  DESCRIPTION:=Fortune mod displays fortune cookies on demand
   URL:=http://freeware.sgi.com/source/fortune-mod
 endef
 
+define Package/fortune-mod/description
+Fortune mod displays fortune cookies on demand
+endef
+
 define Build/Compile
-       $(HOSTCC) -Wall -m32 -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
+       $(HOSTCC) -Wall -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
        $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/datfiles/fortunes $(PKG_BUILD_DIR)/datfiles/fortunes.dat
        $(MAKE) -C $(PKG_BUILD_DIR)/fortune
 endef