strongswan: add missing patch for avoiding collisions with uclibc functions
[openwrt/svn-archive/archive.git] / utils / fowsr / Makefile
index 703f16b18db1235b0a98e569603d28ac0e651290..2bf4d01ddf4bf6911ed2a296c2e47cd6b9fe00d5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,19 +8,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fowsr
-PKG_VERSION:=1.0
-PKG_RELEASE:=20100501
+PKG_VERSION:=2.0-131015
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE).tar.gz
-PKG_SOURCE_URL:=http://fowsr.googlecode.com/files
-PKG_MD5SUM:=aab66ea115fb304e0f5a6171dd6df2ba
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://fowsr.googlecode.com/svn/tags/Releases/
+PKG_MD5SUM:=7f78e8d2b1a162a99e684cab49a210a0
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).src
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/fowsr
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libusb
+  DEPENDS:=+libusb-compat
   TITLE:=Fine Offset Wireless Weather Station Reader
   URL:=http://fowsr.googlecode.com/
 endef
@@ -28,19 +30,15 @@ endef
 define Package/fowsr/description
   fowsr is a USB Data Collector application for WH1080 compatible
   weather stations.
-  Output formats includes Wunderground.com and pywws.
-  See http://www.foshk.com for details and download of the
-  EasyWeather application.
-  All weather stations that can use the EasyWeather application
-  will work with this software.
+  Output formats include XML, Wunderground.com and pywws.
 endef
 
-CONFIGURE_ARGS += \
-       --with-linux-headers="$(LINUX_DIR)" \
-
 define Package/fowsr/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/fowsr $(1)/usr/bin/
+       $(INSTALL_BIN) \
+               $(PKG_BUILD_DIR)/{fowsr,pwsweather,pywws,wunderground,xml}.sh \
+               $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fowsr))