[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / utils / gnokii / Makefile
index e74256f19a106b5bd560154db2fa52a9b1b313d6..eff5f1fc9f9dcd45634a04be7ed3565f2fdcbbd4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnokii
 PKG_VERSION:=0.6.21
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://gnokii.org/download/gnokii/0.6.x
 PKG_MD5SUM:=bbf0aabe2436d8e927f3e2edb4efcac8
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gnokii
@@ -45,13 +47,7 @@ define Build/Configure
                )
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/gnokii/install  
+define Package/gnokii/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/usr/lib