gnupg:
[openwrt/svn-archive/archive.git] / utils / gnupg / Makefile
index e928ca88e73fdf3e25bcc0271aa49c5196304347..a49a0616104b71132b3c5b1a4be972c4a8b8381c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,55 +9,53 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnupg
-PKG_VERSION:=1.4.2.1
+PKG_VERSION:=1.4.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
        ftp://ftp.gnupg.org/gcrypt/gnupg
-PKG_MD5SUM:=2d59ed50d92f69994dbfbe00fe1612e4
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=b06a141cca5cd1a55bbdd25ab833303c
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gnupg
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=GNU Privacy Guard
-  DESCRIPTION:=\
-       GPG is an encryption program.
+  DEPENDS:=+zlib +libncurses +libreadline
+  TITLE:=GNU privacy guard - a free PGP replacement
   URL:=http://www.gnupg.org/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-rpath \
-               --with-gnu-ld \
-               --disable-asm \
-               --disable-gnupg-iconv \
-               --disable-card-support \
-               --disable-agent-support \
-               --disable-bzip2 \
-               --disable-exec \
-               --disable-ldap \
-               --disable-hkp \
-               --disable-finger \
-               --disable-ftp \
-               --disable-dns-srv \
-               --enable-fake-curl \
-               --disable-regex \
-       )
+define Package/gnupg/description
+ GnuPG is GNU's tool for secure communication and data storage.
+ It can be used to encrypt data and to create digital signatures.
+ It includes an advanced key management facility and is compliant
+ with the proposed OpenPGP Internet standard as described in RFC2440.
+ GnuPG does not use any patented algorithms so it cannot be compatible
+ with PGP2 because it uses IDEA (which is patented worldwide). 
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
-endef
+CONFIGURE_ARGS += \
+       --disable-rpath \
+       --disable-asm \
+       --disable-gnupg-iconv \
+       --disable-card-support \
+       --disable-agent-support \
+       --disable-bzip2 \
+       --disable-exec \
+       --disable-ldap \
+       --disable-hkp \
+       --disable-finger \
+       --disable-ftp \
+       --disable-dns-srv \
+       --enable-fake-curl \
+       --disable-regex \
 
 define Package/gnupg/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/g10/gpg $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/g10/gpg $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,gnupg))