[package] update gnupg to 1.4.10 (#5795)
[openwrt/svn-archive/archive.git] / utils / gnupg / Makefile
index 8bf46c48ba2a689c41c50173b87b92b752a85c55..b64c08f2539cca29d93c098a30ff2203197d832d 100644 (file)
@@ -1,89 +1,63 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnupg
-PKG_VERSION:=1.4.2.1
+PKG_VERSION:=1.4.10
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
        ftp://ftp.gnupg.org/gcrypt/gnupg
-PKG_MD5SUM:=2d59ed50d92f69994dbfbe00fe1612e4
-PKG_CAT:=bzcat
+PKG_MD5SUM:=dcf7ed712997888d616e029637bfc303
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gnupg
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=GNU Privacy Guard
-  DESCRIPTION:=GNU Privacy Guard (GnuPG).\\\
-    GPG is an encryption program.
+  DEPENDS:=+zlib +libncurses +libreadline
+  TITLE:=GNU privacy guard - a free PGP replacement
   URL:=http://www.gnupg.org/
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_c_bigendian=no \
-               ac_cv_sizeof_off_t=8 \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --disable-asm \
-                       --disable-gnupg-iconv \
-                       --disable-card-support \
-                       --disable-agent-support \
-                       --disable-bzip2 \
-                       --disable-exec \
-                       --disable-ldap \
-                       --disable-hkp \
-                       --disable-finger \
-                       --disable-ftp \
-                       --disable-dns-srv \
-                       --enable-fake-curl \
-                       --disable-nls \
-                       --disable-rpath \
-                       --disable-regex \
-       );
+define Package/gnupg/description
+ GnuPG is GNU's tool for secure communication and data storage.
+ It can be used to encrypt data and to create digital signatures.
+ It includes an advanced key management facility and is compliant
+ with the proposed OpenPGP Internet standard as described in RFC2440.
+ .
+ GnuPG does not use any patented algorithms so it cannot be compatible
+ with PGP2 because it uses IDEA (which is patented worldwide).
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
-endef
+CONFIGURE_ARGS += \
+       --disable-rpath \
+       --disable-asm \
+       --disable-gnupg-iconv \
+       --disable-card-support \
+       --disable-agent-support \
+       --disable-bzip2 \
+       --disable-exec \
+       --disable-ldap \
+       --disable-hkp \
+       --disable-finger \
+       --disable-ftp \
+       --disable-dns-srv \
+       --enable-fake-curl \
+       --disable-regex \
+
+MAKE_FLAGS += \
+       SUBDIRS="m4 intl zlib util mpi cipher tools g10 keyserver ${checks}" \
 
 define Package/gnupg/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/g10/gpg $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/g10/gpg $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,gnupg))