[package] update gnupg to 1.4.10 (#5795)
[openwrt/svn-archive/archive.git] / utils / gnupg / Makefile
index a49a0616104b71132b3c5b1a4be972c4a8b8381c..b64c08f2539cca29d93c098a30ff2203197d832d 100644 (file)
@@ -1,21 +1,20 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnupg
-PKG_VERSION:=1.4.7
+PKG_VERSION:=1.4.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
        ftp://ftp.gnupg.org/gcrypt/gnupg
-PKG_MD5SUM:=b06a141cca5cd1a55bbdd25ab833303c
+PKG_MD5SUM:=dcf7ed712997888d616e029637bfc303
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,9 +31,9 @@ define Package/gnupg/description
  It can be used to encrypt data and to create digital signatures.
  It includes an advanced key management facility and is compliant
  with the proposed OpenPGP Internet standard as described in RFC2440.
+ .
  GnuPG does not use any patented algorithms so it cannot be compatible
- with PGP2 because it uses IDEA (which is patented worldwide). 
+ with PGP2 because it uses IDEA (which is patented worldwide).
 endef
 
 CONFIGURE_ARGS += \
@@ -53,6 +52,9 @@ CONFIGURE_ARGS += \
        --enable-fake-curl \
        --disable-regex \
 
+MAKE_FLAGS += \
+       SUBDIRS="m4 intl zlib util mpi cipher tools g10 keyserver ${checks}" \
+
 define Package/gnupg/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/g10/gpg $(1)/usr/bin/