[package] update gnupg to 1.4.10 (#5795)
[openwrt/svn-archive/archive.git] / utils / gnupg / Makefile
index dd81afb94396e639f7e8bde81b3dc59b4904cdac..b64c08f2539cca29d93c098a30ff2203197d832d 100644 (file)
@@ -1,58 +1,59 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnupg
-PKG_VERSION:=1.4.2.1
+PKG_VERSION:=1.4.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
        ftp://ftp.gnupg.org/gcrypt/gnupg
-PKG_MD5SUM:=2d59ed50d92f69994dbfbe00fe1612e4
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=dcf7ed712997888d616e029637bfc303
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gnupg
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=GNU Privacy Guard
-  DESCRIPTION:=\
-       GPG is an encryption program.
+  DEPENDS:=+zlib +libncurses +libreadline
+  TITLE:=GNU privacy guard - a free PGP replacement
   URL:=http://www.gnupg.org/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-rpath \
-               --disable-asm \
-               --disable-gnupg-iconv \
-               --disable-card-support \
-               --disable-agent-support \
-               --disable-bzip2 \
-               --disable-exec \
-               --disable-ldap \
-               --disable-hkp \
-               --disable-finger \
-               --disable-ftp \
-               --disable-dns-srv \
-               --enable-fake-curl \
-               --disable-regex \
-       )
+define Package/gnupg/description
+ GnuPG is GNU's tool for secure communication and data storage.
+ It can be used to encrypt data and to create digital signatures.
+ It includes an advanced key management facility and is compliant
+ with the proposed OpenPGP Internet standard as described in RFC2440.
+ .
+ GnuPG does not use any patented algorithms so it cannot be compatible
+ with PGP2 because it uses IDEA (which is patented worldwide).
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
-endef
+CONFIGURE_ARGS += \
+       --disable-rpath \
+       --disable-asm \
+       --disable-gnupg-iconv \
+       --disable-card-support \
+       --disable-agent-support \
+       --disable-bzip2 \
+       --disable-exec \
+       --disable-ldap \
+       --disable-hkp \
+       --disable-finger \
+       --disable-ftp \
+       --disable-dns-srv \
+       --enable-fake-curl \
+       --disable-regex \
+
+MAKE_FLAGS += \
+       SUBDIRS="m4 intl zlib util mpi cipher tools g10 keyserver ${checks}" \
 
 define Package/gnupg/install
        $(INSTALL_DIR) $(1)/usr/bin