[Packages] utils/hdparm: Update to 8.1
[openwrt/svn-archive/archive.git] / utils / hdparm / Makefile
index 0fef9b6e1cdf7a6c392fe1ee5f108bdb9d939d28..2a201b7db00f0029a7c373b1e47dd69c0423656d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hdparm
-PKG_VERSION:=6.6
+PKG_VERSION:=8.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/hdparm
-PKG_MD5SUM:=ecea69f775396e4ab6112dcf9066239f
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=87c1512497195204034503665f71f5fc
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,26 +22,22 @@ define Package/hdparm
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Hard disk drive configuration utilitity
-  DESCRIPTION:=\
-       Tune hard disk parameters for high performance.\\\
-       Get/set hard disk parameters for Linux IDE drives.\\\
-       Primary use is for enabling irq-unmasking and IDE multiplemode.
   URL:=http://sourceforge.net/projects/hdparm/
 endef
 
-define Build/Configure
+define Package/hdparm/description
+       Tune hard disk parameters for high performance.
+       Get/set hard disk parameters for Linux IDE drives.
+       Primary use is for enabling irq-unmasking and IDE multiplemode.
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(EXTRA_CFLAGS)" \
-               LDFLAGS="$(EXTRA_LDFLAGS)" \
-       )
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(EXTRA_CFLAGS)" \
+       LDFLAGS="$(EXTRA_LDFLAGS)" \
 
 define Package/hdparm/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hdparm $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin
 endef
 
 $(eval $(call BuildPackage,hdparm))