packages: forgot an updated bluez-utils patch
[openwrt/svn-archive/archive.git] / utils / hdparm / Makefile
index 9328b07e22e9b32de216e8592d8371c1dd53e235..4704a6a93f778c1fa14efe22a67ac85e9970c472 100644 (file)
@@ -12,13 +12,11 @@ PKG_NAME:=hdparm
 PKG_VERSION:=6.6
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/hdparm
 PKG_MD5SUM:=ecea69f775396e4ab6112dcf9066239f
-PKG_CAT:=zcat
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,19 +24,28 @@ define Package/hdparm
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Hard disk drive configuration utilitity
-  DESCRIPTION:=Hard disk drive configuration utilitity.\\\
-    Tune hard disk parameters for high performance.\\\
-    Get/set hard disk parameters for Linux IDE drives.\\\
-    Primary use is for enabling irq-unmasking and IDE multiplemode.
   URL:=http://sourceforge.net/projects/hdparm/
 endef
 
+define Package/hdparm/description
+       Tune hard disk parameters for high performance.
+       Get/set hard disk parameters for Linux IDE drives.
+       Primary use is for enabling irq-unmasking and IDE multiplemode.
+endef
+
 define Build/Configure
 endef
 
+define Build/Compile
+       $(call Build/Compile/Default, \
+               CFLAGS="$(EXTRA_CFLAGS)" \
+               LDFLAGS="$(EXTRA_LDFLAGS)" \
+       )
+endef
+
 define Package/hdparm/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/hdparm $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hdparm $(1)/usr/sbin
 endef
 
 $(eval $(call BuildPackage,hdparm))