[package] update hdparm to 9.27 (#5965)
[openwrt/svn-archive/archive.git] / utils / hdparm / Makefile
index 9328b07e22e9b32de216e8592d8371c1dd53e235..74e69b71ec470d0ca1931adb69a80ce276afbcd2 100644 (file)
@@ -1,44 +1,43 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hdparm
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hdparm
-PKG_VERSION:=6.6
+PKG_VERSION:=9.27
 PKG_RELEASE:=1
 
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/hdparm
-PKG_MD5SUM:=ecea69f775396e4ab6112dcf9066239f
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=e652dabb6c9233fb8a23ef60a17a1829
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hdparm
   SECTION:=utils
   CATEGORY:=Utilities
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hdparm
   SECTION:=utils
   CATEGORY:=Utilities
+  SUBMENU:=disc
   TITLE:=Hard disk drive configuration utilitity
   TITLE:=Hard disk drive configuration utilitity
-  DESCRIPTION:=Hard disk drive configuration utilitity.\\\
-    Tune hard disk parameters for high performance.\\\
-    Get/set hard disk parameters for Linux IDE drives.\\\
-    Primary use is for enabling irq-unmasking and IDE multiplemode.
   URL:=http://sourceforge.net/projects/hdparm/
 endef
 
   URL:=http://sourceforge.net/projects/hdparm/
 endef
 
-define Build/Configure
+define Package/hdparm/description
+       Tune hard disk parameters for high performance.
+       Get/set hard disk parameters for Linux IDE drives.
+       Primary use is for enabling irq-unmasking and IDE multiplemode.
 endef
 
 endef
 
+MAKE_FLAGS += \
+       CFLAGS="$(EXTRA_CFLAGS)" \
+       LDFLAGS="$(EXTRA_LDFLAGS)" \
+
 define Package/hdparm/install
 define Package/hdparm/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/hdparm $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/sbin
 endef
 
 $(eval $(call BuildPackage,hdparm))
 endef
 
 $(eval $(call BuildPackage,hdparm))