Did not see r12158, do not duplicate this patch
[openwrt/svn-archive/archive.git] / utils / heyu / Makefile
index 3b150261fd3fda824a2da539b91829db04ba6ec7..345c394a0b4763c348b68d897de90c1cda002e74 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=heyu
-PKG_VERSION:=2.0beta.5
+PKG_VERSION:=2.3.2
 PKG_RELEASE:=1
 
-PKG_SOURCE:=heyu-$(PKG_VERSION).tgz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://heyu.tanj.com/download/
-PKG_MD5SUM:=8289d5ca5b972333a72bc0fc3e640c13
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=af3eeeaa8c432e5b3510f4df6dd39f4f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,6 +26,18 @@ define Package/heyu
   URL:=http://heyu.tanj.com/heyu2/
 endef
 
+define Package/heyu/description
+       HEYU is a text-based console program for remotely controlling lights
+       and appliances in the home or office.   It is made available under a
+       free and open source license.
+
+       Heyu uses the CM11A computer interface to send and receive X10 control
+       signals over the AC power lines to modules which can turn On, Off, or
+       Dim attached lamps or appliances.   It can store a schedule of timed
+       events in the CM11A memory for execution when the computer is turned
+       off or disconnected.
+endef
+
 define Package/heyu/conffiles
 /etc/heyu/x10.conf
 endef