add libtool fixes, cleanup
[openwrt/svn-archive/archive.git] / utils / heyu / Makefile
index 37d528d8b071783ce99c77ee4cffb981fcad4810..3b150261fd3fda824a2da539b91829db04ba6ec7 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,12 +11,14 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=heyu
 PKG_VERSION:=2.0beta.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=8289d5ca5b972333a72bc0fc3e640c13
-PKG_SOURCE_URL:=http://heyu.tanj.com/download/
+
 PKG_SOURCE:=heyu-$(PKG_VERSION).tgz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://heyu.tanj.com/download/
+PKG_MD5SUM:=8289d5ca5b972333a72bc0fc3e640c13
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/heyu
@@ -23,7 +26,6 @@ define Package/heyu
   CATEGORY:=Utilities
   DEPENDS:=+setserial
   TITLE:=X10 home automation control using a CM11A
-  DESCRIPTION:=10 home automation control using the CM11A serial device.
   URL:=http://heyu.tanj.com/heyu2/
 endef
 
@@ -31,17 +33,17 @@ define Package/heyu/conffiles
 /etc/heyu/x10.conf
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld" \
-               CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT -DHASTZ"
+define Build/Compile
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) \$$$$(DFLAGS)" \
+       )
 endef
 
 define Package/heyu/install    
-       install -d -m0755 $(1)/etc/$(PKG_NAME)
-       install -m0644 ./files/x10.conf $(1)/etc/$(PKG_NAME)/x10.conf
-       install -d -m0755 $(1)/usr/bin
-       install -m0644 $(PKG_BUILD_DIR)/heyu $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/heyu $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
+       $(INSTALL_DATA) ./files/x10.conf $(1)/etc/$(PKG_NAME)/x10.conf
 endef
 
 $(eval $(call BuildPackage,heyu))