hplip: disable dbus support
[openwrt/svn-archive/archive.git] / utils / hplip / Makefile
index 8ea9e734e80f580b9b8ebf3ed3626d43b31d7af7..536017d43373937e9d22532157575e8008f1a80f 100644 (file)
@@ -4,17 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hplip
-PKG_VERSION:=2.7.12
+PKG_VERSION:=2.8.9
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/hplip
-PKG_MD5SUM:=ba00337ccf1b520509518bffbec960db
+PKG_MD5SUM:=2e20dba86abb99a3ca59d05e814ce9a1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_DEPENDS := python
@@ -39,7 +38,16 @@ CONFIGURE_ARGS += \
        --disable-fax-build \
        --disable-pp-build \
        --disable-doc-build \
-       --disable-foomatic-xml-install
+       --disable-foomatic-xml-install \
+       --disable-dbus-build
+
+define Build/Configure
+       $(call Build/Configure/Default,\
+               $(CONFIGURE_ARGS),\
+               ac_cv_lib_cups_cupsDoFileRequest=yes \
+               LIBS="-ljpeg -lusb" \
+       )
+endef
 
 define Package/hplip/install
        $(INSTALL_DIR) $(1)/usr/lib