[PATCH] update joe package, support for all emulation modes.
[openwrt/svn-archive/archive.git] / utils / joe / Makefile
index c1a89d2a6c7e7f40f54401a5dccb58208699e555..875a7fd86b49af957db7dba696cb1e8f921bcd1a 100644 (file)
@@ -5,16 +5,23 @@
 # See /LICENSE for more information.
 #
 
+# changes by David Kuehling <dvdkhlng TA gmx TOD de>:
+#
+#  - include support for all emulation modes jmacs jpico etc.
+#  - see patches/002-builtinrc.patch
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=joe
 PKG_VERSION:=3.7
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/joe-editor
 PKG_MD5SUM:=66de1b073e869ba12abbfcde3885c577
 
+PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/joe
@@ -27,12 +34,16 @@ define Package/joe
 endef
 
 define Package/joe/description
-Joe is world-famous Wordstar like text editor.
+Joe is world-famous Wordstar like text editor, that also features 
+Emacs and Pico emulation
 endef
 
 define Package/joe/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/joe $(1)/usr/bin/
+       for i in jmacs jstar rjoe jpico; do \
+         ln -sf joe $(1)/usr/bin/$$$$i; \
+       done
 endef
 
 $(eval $(call BuildPackage,joe))