add mutella (thanks to olli)
[openwrt/svn-archive/archive.git] / utils / joe / Makefile
index 7c36bdd43cf00cec6cf0ff70a5149c8f39520b66..e569b098d6ab0ebb6df2b08da0922eb89c7bb712 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,24 +15,19 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/joe-editor
 PKG_MD5SUM:=9bdffecce7ef910feaa06452d48843de
-PKG_CAT:=zcat
-
-PKG_BUILD_DEPENDS:=libncurses
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/joe
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=+libncurses
   TITLE:=JOE - Joes own editor
   DESCRIPTION:=Joe is world-famous Wordstar like text editor.
   URL:=http://sourceforge.net/projects/joe-editor/
 endef
 
 define Package/joe/install
-       $(STRIP) $(PKG_BUILD_DIR)/joe
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/joe $(1)/usr/bin/
 endef