Fix compilation when modules are selected or not, should fix buildbot spam :p
[openwrt/svn-archive/archive.git] / utils / lcd4linux / Makefile
index 264c3856abb5ce11d8f45d4f7c40e16175a445d0..50c48caddbf0d3ebf65b9f4acb0923c55f464ed1 100644 (file)
@@ -33,10 +33,18 @@ define Package/lcd4linux
   URL:=http://lcd4linux.bulix.org/
 endef
 
-# commas are interpreted by the $(call ...) macro, so define a intermediate variable holding our drivers spec
+# commas are interpreted by the $(call ...) macro, so define an intermediate variable holding our drivers spec
 PKG_CONFIGURE_DRIVERS:=all,!PNG,!RouterBoard,!X11
 
 define Build/Configure
+        (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               aclocal.m4 \
+               Makefile.in \
+               configure \
+               stamp-h.in \
+               config.h.in \
+       );
        $(call Build/Configure/Default, \
                --without-x \
                --with-drivers="$(PKG_CONFIGURE_DRIVERS)" \