fix another unneeded autoheader invocation
[openwrt/svn-archive/archive.git] / utils / lcd4linux / Makefile
index 2af009b48bf4f2419c18503ffd1b85aaf27f79c4..50c48caddbf0d3ebf65b9f4acb0923c55f464ed1 100644 (file)
@@ -12,13 +12,14 @@ PKG_NAME:=lcd4linux
 PKG_VERSION:=0.10.0+cvs20051015
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/lcd4linux/ \
                http://ftp.de.debian.org/debian/pool/main/l/lcd4linux/
 PKG_MD5SUM:=5b5ac629be4bb5c29104fb8f6b7fa444
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lcd4linux
@@ -26,51 +27,38 @@ define Package/lcd4linux
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=LCD display utility
-  DESCRIPTION:=LCD display utility.\\\
-    LCD4Linux is a small program that grabs information from the kernel and \\\
-    some subsystems and displays it on an external liquid crystal display.
+  DESCRIPTION:=\
+       LCD4Linux is a small program that grabs information from the kernel and \\\
+       some subsystems and displays it on an external liquid crystal display.
   URL:=http://lcd4linux.bulix.org/
 endef
 
+# commas are interpreted by the $(call ...) macro, so define an intermediate variable holding our drivers spec
+PKG_CONFIGURE_DRIVERS:=all,!PNG,!RouterBoard,!X11
+
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --without-x \
-                       --with-drivers='all,!PNG,!RouterBoard,!X11' \
-                       --with-plugins=wireless \
+        (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               aclocal.m4 \
+               Makefile.in \
+               configure \
+               stamp-h.in \
+               config.h.in \
        );
+       $(call Build/Configure/Default, \
+               --without-x \
+               --with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
+               --with-plugins=wireless \
+       )
 endef
 
 define Build/Compile
-  $(call Build/Compile/Default, CFLAGS="$(TARGET_CFLAGS) -Wall")
+       $(MAKE) -C $(PKG_BUILD_DIR)
 endef
 
 define Package/lcd4linux/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/lcd4linux $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lcd4linux $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,lcd4linux))