Fix compilation when modules are selected or not, should fix buildbot spam :p
[openwrt/svn-archive/archive.git] / utils / lcd4linux / Makefile
index 81bb3c15e280156551fd17eef13a326c81ff7826..50c48caddbf0d3ebf65b9f4acb0923c55f464ed1 100644 (file)
@@ -33,10 +33,18 @@ define Package/lcd4linux
   URL:=http://lcd4linux.bulix.org/
 endef
 
-# commas are interpreted by the $(call ...) macro, so define a intermediate variable holding our drivers spec
+# commas are interpreted by the $(call ...) macro, so define an intermediate variable holding our drivers spec
 PKG_CONFIGURE_DRIVERS:=all,!PNG,!RouterBoard,!X11
 
 define Build/Configure
+        (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               aclocal.m4 \
+               Makefile.in \
+               configure \
+               stamp-h.in \
+               config.h.in \
+       );
        $(call Build/Configure/Default, \
                --without-x \
                --with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
@@ -49,8 +57,8 @@ define Build/Compile
 endef
 
 define Package/lcd4linux/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/lcd4linux $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lcd4linux $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,lcd4linux))