remove useless xorg macros patch
[openwrt/svn-archive/archive.git] / utils / lcd4linux / Makefile
index 50c48caddbf0d3ebf65b9f4acb0923c55f464ed1..b0564cca8aab35f7925fbffbec4df005d19c9b5f 100644 (file)
@@ -10,13 +10,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lcd4linux
 PKG_VERSION:=0.10.0+cvs20051015
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/lcd4linux/ \
-               http://ftp.de.debian.org/debian/pool/main/l/lcd4linux/
+       http://ftp.de.debian.org/debian/pool/main/l/lcd4linux/
 PKG_MD5SUM:=5b5ac629be4bb5c29104fb8f6b7fa444
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
 
@@ -36,8 +35,13 @@ endef
 # commas are interpreted by the $(call ...) macro, so define an intermediate variable holding our drivers spec
 PKG_CONFIGURE_DRIVERS:=all,!PNG,!RouterBoard,!X11
 
+CONFIGURE_ARGS += \
+       --without-x \
+       --with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
+       --with-plugins=wireless
+
 define Build/Configure
-        (cd $(PKG_BUILD_DIR); touch \
+       (cd $(PKG_BUILD_DIR); touch \
                configure.in \
                aclocal.m4 \
                Makefile.in \
@@ -45,15 +49,7 @@ define Build/Configure
                stamp-h.in \
                config.h.in \
        );
-       $(call Build/Configure/Default, \
-               --without-x \
-               --with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
-               --with-plugins=wireless \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
+       $(call Build/Configure/Default)
 endef
 
 define Package/lcd4linux/install