replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / utils / lilo / Makefile
index 3e7ce415c61bea2728389ce2fb35411af66973ad..1f31d59eeccba37be01c2089e1dc9837bd039dd1 100644 (file)
@@ -35,15 +35,20 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) alles
-       $(STRIP) $(PKG_BUILD_DIR)/lilo.static
 endef
 
 define Package/lilo/install
-       install -d -m0755 $(1)/sbin
+       $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_BUILD_DIR)/lilo.static $(1)/sbin/lilo
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) ./files/lilo.conf $(1)/etc/
        $(CP) ./files/boot.msg $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,lilo))
+
+$(foreach command, as86 ld86, \
+  $(eval $(call RequireCommand,$(command), \
+   $(PKG_NAME) requires $(command). \
+  )) \
+)